Splunk® IT Service Intelligence

Entity Integrations Manual

Acrobat logo Download manual as PDF


Acrobat logo Download topic as PDF

Unix and Linux integration requirements in ITSI for collectd

These are the requirements and compatible software for *nix integrations for Splunk IT Service Intelligence (ITSI) entity integrations for collectd. For information about data you can collect with this integration, see *nix data you can collect with ITSI.

If you want to collect data from a system running SELinux, see Collect data in ITSI with SELinux.

*nix integration operating system support

*nix integrations support only 64-bit operating systems.

You can collect metrics and log data from the following operating systems and versions:

Operating system Version
Red Had Enterprise Linux 6, 7, 8
CentOS 6, 7, 8
Debian 7, 8, 9, 10
Ubuntu 14, 16, 18, 20
Fedora 25, 26, 27, 28, 29, 30, 31, 32
Solaris 10, 11 (x86_64 only)
SUSE Enterprise 15
openSUSE 15

collectd support for *nix hosts

ITSI uses collectd to collect metrics data from *nix hosts. Collectd is an open source daemon that collects system and application performance metrics. For more information about collectd, see A Beginner's Guide to collectd on the main Splunk website.

For information about how ITSI uses collectd for each operating system, see collectd package sources, install commands, and locations for ITSI entity integrations.

ITSI entity integrations are compatible with these versions of collectd:

  • 5.7.x
  • 5.8.x
  • 5.9.x
  • 5.10.x
  • 5.11.x

Required *nix dependencies

You need these dependencies on each *nix host you want to collect data from:

Host type Dependency
Every host
  • wget
  • Debian
  • Ubuntu
apt-get
  • Red Hat Enterprise Linux
  • CentOS
  • Fedora
yum
  • SUSE
  • openSUSE
zypper

Docker (no orchestration) data collection requirements

You can monitor Docker containers on a Linux system you didn't deploy with an orchestration tool like Kubernetes or OpenShift. You can't monitor Docker containers on a Unix system.

These are the Docker requirements:

  • Docker version 1.18 or later
  • Docker API version 1.20 or later
  • libyajl2
Last modified on 21 July, 2020
PREVIOUS
About Unix and Linux entity integration in ITSI
  NEXT
*nix data you can collect with collectd in ITSI

This documentation applies to the following versions of Splunk® IT Service Intelligence: 4.6.0 Cloud only, 4.6.1 Cloud only, 4.6.2 Cloud only, 4.7.0, 4.7.1, 4.7.2, 4.8.0 Cloud only, 4.8.1 Cloud only, 4.9.0, 4.9.1, 4.9.2, 4.9.3, 4.9.4, 4.10.0 Cloud only, 4.10.1 Cloud only, 4.10.2 Cloud only


Was this documentation topic helpful?

You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters