Splunk® IT Service Intelligence

Install and Upgrade Manual

Acrobat logo Download manual as PDF


This documentation does not apply to the most recent version of ITSI. Click here for the latest version.
Acrobat logo Download topic as PDF

ITSI compatibility with related apps and add-ons

This table lists versions of IT Service Intelligence (ITSI) and their compatible versions of the following related products:

  • The Machine Learning Toolkit (MLTK) is required if you want to leverage ITSI's Predictive Analytics functionality. For more information, see Set up Predictive Analytics in ITSI.
  • The Common Information Model (CIM) is required for bidirectional ticketing with ServiceNow. For more information, see Overview of episode actions in ITSI.
  • The Splunk Add-on for ServiceNow is required for integration with ServiceNow.

For compatibility between ITSI and Splunk Enterprise versions, see the Splunk products version compatibility matrix.

For compatibility between Splunk Enterprise and other Splunk apps and add-ons, see the specific app or add-on page on Splunkbase.

For instructions on upgrading ITSI, see Plan an upgrade of IT Service Intelligence.

IT Service Intelligence (ITSI) Splunk App for Infrastructure (SAI) Machine Learning Toolkit (MLTK) Common Information Model (CIM) Splunk Add-on for ServiceNow
4.9.x 2.2.1, 2.2.2, 2.2.3 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x, 6.x, 7.0.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.18.0 Python 2: 4.x - 5.x
4.8.x (Cloud only) 2.2.1, 2.2.2, 2.2.3 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x, 6.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.18.0 Python 2: 4.x - 5.x
4.7.x 2.2.1, 2.2.2 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x, 6.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.18.0 Python 2: 4.x - 5.x
4.6.x (Cloud only) 2.2.0, 2.2.1 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x, 6.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.18.0 Python 2: 4.x - 5.x
4.5.x (Cloud only) 2.1.0, 2.1.1 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x, 6.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.18.0 Python 2: 4.x - 5.x
4.4.x 2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4 Python 3: 5.x Python 3: 4.14.0 - 4.18.0 Python 3: 5.0.x
Python 2: 3.2.0 - 4.4.2 Python 2: 4.13.0 - 4.14.0 Python 2: 4.x - 5.x
4.3.x 1.3.0, 1.3.1

1.4.0, 1.4.1

3.2.0 - 4.4.2 4.12.0 4.0.0
4.2.x 1.3.0, 1.3.1

1.4.0, 1.4.1

3.2.0 - 4.4.2 4.11.0 3.1.0
4.1.x 1.2.0 3.2.0 - 4.4.2 N/A 3.0.0 - 3.1.0
4.0.x 1.2.0 3.2.0 - 4.4.2 N/A 3.0.0 - 3.1.0
Last modified on 29 June, 2021
PREVIOUS
Plan your ITSI deployment
  NEXT
Python 3 migration with ITSI

This documentation applies to the following versions of Splunk® IT Service Intelligence: 4.9.1, 4.9.2, 4.9.3


Was this documentation topic helpful?

You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters