Content Pack for Third-party APM

Content Pack for Third-party APM

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Troubleshoot the Content Pack for Third-party APM

The Content Pack for Third-party APM relies on the Splunk Add-on for AppDynamics, the DynaTrace Add-on for Splunk, and the Splunk Add-on for New Relic for input collection. When troubleshooting, determine whether the issue you are experiencing is relevant to the content pack or to any of the add-ons.

Refer to the following general troubleshooting guidelines:

  • If your data successfully reaches your Splunk indexes, the content pack requires troubleshooting.
  • If data isn't reaching your Splunk indexes, then check for configuration problems with the accounts and inputs handled by the add-ons.

Here are some common issues in Content Pack for Third-party APM and how to resolve them.

The Service Tree isn't lighting up or not all entities are displaying for KPIs

Problem

The Service Tree doesn't light up or not all entities are displaying for the KPIs.

Cause

KPIs are scheduled to run every 5 minutes with a 5-minute calculation window. If data is being sent to Splunk at an interval greater than 5 minutes, it might cause the entity to drop from the service tree.

Solution

In ITSI or IT Essentials Work, go to Configuration > KPI Base Searches and filter for DA-ITSI-APM.

For each of the base searches, perform the following steps:

  1. Determine the Monitoring Lag.
  2. Increase the Calculation Window.
  3. Repeat the previous steps for all DA-ITSI-APM base searches.

Determine the Monitoring Lag

To determine your recommended lag, select "Determine Recommended Lag" under Monitoring Lag in a base search. This runs a search and displays the recommended monitoring lag, as well as the maximum, average and minimum indexing lag.

If the recommended lag is less than 300, copy over the recommended monitoring lag into the base search and save. You can skip the second step in this case. If the recommended lag is greater than or equal to 300, keep the monitoring lag at 30 seconds in the base search and complete the second step.

To learn more, see Define KPI unit and monitoring lag in ITSI in the Service Insights Manual.

Increase the Calculation Window

In the base search, increase the Calculation Window and KPI Search Schedule to "Last 15 minutes" and save.

Repeat the previous steps for all DA-ITSI-APM base searches
Repeat steps 1 and 2 for the remaining DA-ITSI-APM base searches.

Last modified on 20 January, 2022
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This documentation applies to the following versions of Content Pack for Third-party APM: 1.0.1, 1.1.0, 1.2.0


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