Content Pack for Microsoft Exchange

Content Pack for Microsoft Exchange

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This documentation does not apply to the most recent version of Content Pack for Microsoft Exchange. For documentation on the most recent version, go to the latest release.
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Troubleshoot the Content Pack for Microsoft Exchange

The Content Pack for Microsoft Exchange relies on the Splunk Add-on for Microsoft Exchange for input collection and knowledge object management. When troubleshooting, determine whether the issue you are experiencing is relevant to the content pack or to the add-on.

Here are some common issues in the Content Pack for Microsoft Exchange and how to resolve them.

The content pack is not working as expected

Problem

This problem applies to the Content Pack for Microsoft Exchange as included with the Splunk App for Content Packs. This problem does not apply to the content pack as installed using backup and restore functionality.

In some cases, the content pack might not work as expected. For example, you might open the Domain Alias Configuration - Microsoft Exchange dashboard from the Content Pack for Microsoft Exchange for the first time and see the domain aliases configured in the Splunk App for Microsoft Exchange, but not in the Content Pack for Microsoft Exchange.

Cause

Both the Content Pack for Microsoft Exchange and the Splunk App for Microsoft Exchange use the same knowledge objects with the same definitions. If you install both the app and the content pack on the same search head and perform different configurations, knowledge objects might conflict when storing or retrieving configurations.

Solution

You can't install the Splunk App for Microsoft Exchange and the Content Pack for Microsoft Exchange on the same search head. To learn how to correctly install the content pack and the app, see Install and configure the Content Pack for Microsoft Exchange.

"Invalid Data Model" errors in KPIs

Problem

KPIs show an "Invalid Data Model" error.

Cause

The knowledge objects, including macros and data models, can't be found because the sharing settings aren't set to Global. This error only occurs if you are using ITSI version 4.8.x or lower, or IT Essentials Work version 1.1.0 or lower, and installed the content pack using backup and restore functionality.

Solution

Follow the steps to set the permissions for the knowledge objects and then re-install the content pack. For further details, see Install the content pack using backup and restore functionality provided by ITSI and IT Essentials Work.

Last modified on 26 January, 2022
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Dashboard reference for the Content Pack for Microsoft Exchange

This documentation applies to the following versions of Content Pack for Microsoft Exchange: 1.4.3, 1.5.0, 1.5.1, 1.5.2


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