Content Pack for VMware Dashboards and Reports

Content Pack for VMware Dashboards and Reports

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Troubleshoot the Content Pack for VMware Dashboards and Reports

The Content Pack for VMware Dashboards and Reports relies on the Splunk Add-on for VMware Metrics for input collection and knowledge management. When troubleshooting, determine whether the issue you are experiencing is relevant to the content pack or to the add-on.

Here are some common issues in Content Pack for VMware Dashboards and Reports and how to resolve them:

The content pack isn't working as expected

Problem

In some cases, the content pack might not work as expected. For example, the Host or VMs Dropdown list gives the value for the vCenter configured using Splunk Add-on for VMware not the VMs configured using the Splunk Add-on for VMware Metrics.

Cause

There is a conflict with the knowledge objects in the content pack and the Splunk App for VMware.

Solution

Check if the Splunk App for VMware is enabled on the same instance and disable it. If the Splunk App for VMware is not disabled, the Content Pack for VMware Dashboards and Reports uses the configurations and the knowledge object definitions from the app. Enabling the app results in a knowledge object conflict

The dashboards aren't populating even though the data is present

Problem

In some cases, the dashboards and reports in the Content Pack for VMware Dashboards and Reports won't populate even though the data is present. For example, a line chart with no data, blank table columns, or filters not populating.

Cause

The Content Pack for VMware Dashboards and Reports relies on the Splunk Add-on for VMware Metrics. The Splunk Add-on for VMware Metrics collects limited performance metrics with the default configuration. If you are not seeing data it might mean that a metric is not in the default list. This problem can also arise you have configured the Splunk Add-on for VMware instead of Splunk Add-on for VMware Metric.

Solution

You might have to configure the additional metrics or inventory fields to populate the dashboards. To view the additional metrics and inventory fields, see Configure Data Collection for Content Pack for VMware Dashboards and Reports.

Virtual Machine Snapshots dashboard isn't populating with the data collected by Splunk Add-on for VMware Metrics

Problem

The Virtual Machine Snapshots dashboard isn't populated with data.

Cause

The dashboard uses the summarized data present in the VMwareInventory data model, for which data model acceleration must be enabled. The dashboard might not get populated if data model acceleration isn't enabled.

Solution

Enable data model acceleration for the VMwareInventory data model. Users with admin permissions can enable acceleration or change the acceleration period by performing the following steps on the search head:

  1. On the Splunk menu bar, click Settings > Data models.
  2. Select IT Essentials Service Intelligence (ITSI)' or IT Essentials Work from the App drop-down to see the data models defined and used by the app.
  3. From the list for data models, click Edit in the Action column of a data model.
  4. Select Edit Acceleration.
  5. Check the Accelerate checkbox to enable data model acceleration.
  6. Select the summary range to specify the acceleration period. The default summary range is one month.
  7. Click Save.
Last modified on 16 December, 2021
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Dashboard reference for the Content Pack for VMware Dashboards and Reports

This documentation applies to the following versions of Content Pack for VMware Dashboards and Reports: 1.1.1, 1.1.2, 1.1.3, 1.1.4, 1.1.5, 1.2.0


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