Splunk® Enterprise Security

Troubleshoot Splunk Enterprise Security

Troubleshoot dashboards that are not populating in Splunk Enterprise Security

Issue

Dashboards not populating in Splunk Enterprise Security.


Cause

Each dashboard in Enterprise Security references data from various data models. Without the relevant data, the dashboards will remain empty.

Solution

If you expect data to appear, or if the data appearing is older than you expect, follow these troubleshooting steps.

  1. Perform a search against the data model. Click Open in Search in the lower left corner of a dashboard view to perform a direct search against the data model. The New Search dashboard also exposes the search commands and objects used to populate a particular view.
  2. If the search yields no results, determine if any data required for a dashboard is available in the data model.
    1. See the Dashboard requirements matrix in this manual to determine the data model datasets used by a dashboard.
    2. Use the data model and data model dataset to search for events in the data model.
      Action Search Expected Result
      Verify the data is normalized to the Common Information Model | datamodel data_model_name root_object_name search | table _time, sourcetype, root_object_name.*
      For example,

      | datamodel Network_Traffic All_Traffic search | dedup sourcetype | table _time, sourcetype, All_Traffic.*

      Returns a list of sourcetypes and the data model objects and fields populated by that sourcetype.
  3. If no data is available, confirm the data model is being accelerated.
    1. In Enterprise Security, browse to Audit > Data Model Audit.
    2. Review the Acceleration Details panel for information about the data model acceleration status, such as when the latest data model acceleration occurred, or whether it is 100% complete. See Configure data models for Splunk Enterprise Security in the Installation and Upgrade Manual.
  4. If the data model acceleration status is as expected, validate that additional required data sources are available. For example, the User Activity dashboard uses additional data sources.
Dashboard Name Data type Data source
User Activity Lookups The Cloud Domains, Corporate Email Domains, and Corporate Web Domains lookup files.
Identities The Identity fields: bunit, email, watchlist, work_city, work_country, work_lat, and work_long.
Correlation Searches * High Volume Email Activity with Non-corporate Domains
* Watchlisted Event Observed
* Web Uploads to Non-corporate Sites by Users
Access Anomalies Correlation Searches * Impossible Travel Events Detected For Users

See also

For more information on why data might not display in dashboards, see the product documentation:

Last modified on 11 July, 2024
Troubleshoot threat intelligence in Splunk Enterprise Security   Troubleshoot performance issues cause by searches and lookups in Splunk Enterprise Security

This documentation applies to the following versions of Splunk® Enterprise Security: 8.0.0


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