Splunk® Machine Learning Toolkit

ML-SPL API Guide

Download manual as PDF

Download topic as PDF

Known issues

Here are the known issues in each version of the Splunk Machine Learning Toolkit ML-SPL API:

Version 4.4.1

No known issues for version 4.4.1 of the ML-SPL API. Use the following support resources if you encounter an issue.

For custom algorithm and PSC version dependencies, see Custom algorithm and PSC version dependencies.

Version 4.4.0

No known issues for version 4.4.0 of the ML-SPL API. Use the following support resources if you encounter an issue.

For custom algorithm and PSC version dependencies, see Custom algorithm and PSC version dependencies.

Version 4.3.0

No known issues for version 4.3.0 of the ML-SPL API. Please make use of the following support resources should you encounter an issue.

Specific version dependencies

MLTK Version PSC Version
4.3 1.3 or 1.4
4.2 1.3 or 1.4
4.1 1.3
4.0 1.3
3.4 1.3
3.3 1.2 or 1.3
3.2 1.2 or 1.3
3.1 1.2

Linux 32-bit support is not available should you upgrade to version 1.4 of the Python for Scientific Computing add-on.

Version 4.2.0

No known issues for version 4.2.0 of the ML-SPL API. Please make use of the following support resources should you encounter an issue.

Specific version dependencies

MLTK Version PSC Version
4.2 1.3 or 1.4
4.1 1.3
4.0 1.3
3.4 1.3
3.3 1.2 or 1.3
3.2 1.2 or 1.3
3.1 1.2

Linux 32-bit support is not available should you upgrade to version 1.4 of the Python for Scientific Computing add-on.

Version 4.1.0

No known issues for version 4.1.0 of the ML-SPL API. Please make use of the following support resources should you encounter an issue.

Specific version dependencies

MLTK Version PSC Version
4.1 1.3
4.0 1.3
3.4 1.3
3.3 1.2 or 1.3
3.2 1.2 or 1.3
3.1 1.2

Version 4.0.0

No known issues for version 4.0.0 of the ML-SPL API. Please make use of the following support resources should you encounter an issue.

Specific version dependencies

MLTK Version PSC Version
4.0 1.3
3.4 1.3
3.3 1.2 or 1.3
3.2 1.2 or 1.3
3.1 1.2

Version 3.4.0

Description

If you have written any custom algorithms that rely on the PSC libraries, upgrading to the new version of the PSC library (version 1.3) will impact those algorithms. You will need to re-train any models (re-run the search that used the fit command) using those algorithms after you upgrade PSC.

Specific version dependencies

MLTK Version PSC Version
3.4 1.3
3.3 1.2 or 1.3
3.2 1.2 or 1.3
3.1 1.2
PREVIOUS
Support for the ML-SPL API
 

This documentation applies to the following versions of Splunk® Machine Learning Toolkit: 4.4.1


Was this documentation topic helpful?

Enter your email address, and someone from the documentation team will respond to you:

Please provide your comments here. Ask a question or make a suggestion.

You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters