Splunk® Enterprise

Python 3 Migration

Splunk Cloud Platform

Check this manual often for updated information about the Splunk platform Python 3 migration. The content is subject to change.

Support for Python 2 -- and for any app that is compatible only with Python 2 -- is being removed from Splunk Cloud Platform. All apps that use Python should be upgraded to Python 3.7 or higher, and kept current with the latest version of Python, to continue to be deployed in Splunk Cloud Platform. Splunk will upgrade all supported apps vetted for Splunk Cloud Platform as soon as they can be made available.

What Should I Do Next?

To prepare for the removal of Python 2.7, keep all your Splunk-supported apps up to date with their latest versions. The latest version of these apps will be compatible with Python 3.7 for now, and with Python 3.9 once it is available.

Complete the steps below to ensure all 3rd-party Splunkbase and private apps in your Splunk Cloud Platform instances are Python 3 compatible.

1. Splunkbase apps: all Splunk Cloud Platform customers must install Splunk Cloud Platform 8.x or higher compatible versions of all Splunkbase 3rd-party apps. Please note the following regarding Splunkbase apps and Python 3 compatibility:

2. Private apps: all private apps installed in all Splunk Cloud Platform environments need to also be upgraded for Python 3 compatibility. This may apply even if you are already on Splunk Cloud Platform 8.x, since there may be private apps still using Python 2 in your environment. Splunk provides multiple resources to help with the upgrade:

  • To enable better self-service of your apps, leverage the Packaging Toolkit when building your apps.

3. Unused apps: any Splunkbase 3rd-party or private apps that have not been upgraded for Python 3.7 compatibility must be removed from your Splunk Cloud Platform environment.

App submission

Apps vetted for Splunk Cloud Platform must be resubmitted for new Cloud vetting after the app has been made Python 3-compatible.

Ensure that private apps and Splunkbase apps are compatible with Splunk Enterprise version 8.x or higher before submitting them for installation.

Apps for Splunk Cloud Platform will follow the same guidelines as on-premises apps, with the added requirement of passing Cloud vetting.

Last modified on 20 May, 2024
Python 3.7 Code Compatibility   Python with Splunk Enterprise Security

This documentation applies to the following versions of Splunk® Enterprise: 9.0.0, 9.0.1, 9.0.2, 9.0.3, 9.0.4, 9.0.5, 9.0.6, 9.0.7, 9.0.8, 9.0.9, 9.1.0, 9.1.1, 9.1.2, 9.1.3, 9.1.4, 9.2.0, 9.2.1


Was this topic useful?







You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters