Troubleshoot the Splunk Add-on for vCenter Logs
The Splunk Add-on for vCenter Logs isn't receiving data
Problem
The Splunk Add-on for vCenter Logs isn't receiving data.
Cause
If you've configured vCenter Server 5.0 but no data is coming in, the vCenter Server 5.0 and 5.1 are missing WSDL files that are required for Splunk Add-on for VMware to make API calls to vCenter server.
Solution
Resolve this issue by installing the missing VMware WSDL files as documented in the vSphere Web Services SDK WSDL workaround in the VMware documentation.
- reflect-message.xsd
- reflect-types.xsd
Note that the program data folder is typically a hidden folder.
Configure the Splunk Add-on for vCenter logs to collect vCenter log data | Source types for the Splunk Add-on for vCenter Logs |
This documentation applies to the following versions of Splunk® Supported Add-ons: released
Feedback submitted, thanks!