Splunk® User Behavior Analytics

Install and Upgrade Splunk User Behavior Analytics

Acrobat logo Download manual as PDF


Acrobat logo Download topic as PDF

Upgrade a single node RHEL, CentOS, or Oracle Linux installation of Splunk UBA

Before upgrading Splunk UBA on a single server, be sure you have verified the Upgrade Splunk UBA prerequisites.

Upgrade your kernel to the latest version

Perform the steps in the table to upgrade your operating system kernel to the latest version. See Operating system requirements for the specific kernel versions.

Operating System Update Instructions
OEL 7.7, 7.8, 7.9
  1. Run the following command to install yum-utils:
    sudo yum install yum-utils -y
  2. Run the following commands to skip certain packages if they are not available:
    sudo yum-config-manager --disable pgdg94
    sudo yum-config-manager --disable nodesource
    sudo yum-config-manager --disable rhel-7-server-rt-beta-rpms
    
  3. Obtain http://yum.oracle.com/public-yum-ol7.repo and download it to /home/caspida.
    sudo wget http://yum.oracle.com/public-yum-ol7.repo /home/caspida
  4. Copy public-yum-ol7.repo to /etc/yum.repos.d:
    sudo cp /home/caspida/public-yum-ol7.repo /etc/yum.repos.d/public-yum-ol7.repo
  5. Enable the repositories:
    sudo yum-config-manager --enable ol7_UEKR5
    sudo yum-config-manager --enable ol7_addons
    
  6. Update the kernel to the latest version:
    • Run the following command if you are using OEL 7.7:
      sudo yum update --releasever=7.7 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
    • Run the following command if you are using OEL 7.8:
      sudo yum update --releasever=7.8 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
    • Run the following command if you are using OEL 7.9:
      sudo yum update --releasever=7.9 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
RHEL 7.7, 7.8, or 7.9
  1. Enable the repos for required packages:
    • Run the following commands if you are using RHEL 7.7:
      sudo subscription-manager repos --enable=rhel-7-server-extras-rpms
      sudo subscription-manager repos --enable=rhel-7-server-eus-rpms
      sudo subscription-manager repos --enable=rhel-7-server-rpms
      sudo subscription-manager repos --enable=rhel-7-server-optional-rpms
      
    • Run the following commands if you are using RHEL 7.8 or 7.9:
      sudo subscription-manager repos --enable=rhel-7-server-extras-rpms
      sudo subscription-manager repos --enable=rhel-7-server-rpms
      sudo subscription-manager repos --enable=rhel-7-server-optional-rpms
      
  2. Run the following command to install yum-utils:
    sudo yum install yum-utils -y
  3. Run the following commands to skip certain packages if they are not available:
    sudo yum-config-manager --disable pgdg94
    sudo yum-config-manager --disable nodesource
    sudo yum-config-manager --disable rhel-7-server-rt-beta-rpms
    
  4. Update the kernel to the latest version:
    • Run the following command if you are using RHEL 7.7:
      sudo yum update --releasever=7.7 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
    • Run the following command if you are using RHEL 7.8:
      sudo yum update --releasever=7.8 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
    • Run the following command if you are using RHEL 7.9:
      sudo yum update --releasever=7.9 --exclude="zookeeper redis-server redis-tools influxdb nodejs nodejs-docs postgres*" -y
CentOS
(latest kernel)

Run the following command to update your CentOS kernel to the latest available version:

Running this command updates your CentOS kernel to the latest available version. You can't select a specific version. Run this command only if you are sure you want the latest available verison of CentOS

sudo yum update -y

Single server upgrade steps

Ensure that Splunk UBA is running before you upgrade, then perform the following tasks to upgrade Splunk UBA on a single server.

  1. Obtain the Splunk UBA Software Update and download the file to the /home/caspida directory. Select version 5.0.5.1 from the drop-down list. The downloadable archive file is named splunk-uba-software-update_5051.tgz.
  2. Extract the archive with the following command:
    tar xfz /home/caspida/splunk-uba-software-update_5051.tgz -C /home/caspida

    The following files are extracted:

    • splunk-uba-software-update-000004-5051.tgz
    • splunk-uba-software-update-000004-5051.tgz.md5sum
  3. Extract the software update package in the /home/caspida directory:
    tar xfz /home/caspida/splunk-uba-software-update_5051/splunk-uba-software-update-000004-5051.tgz -C /home/caspida
  4. Apply the patch with the following command:
    /home/caspida/patch_uba_5051/bin/utils/patch_uba.sh -p /home/caspida/patch_uba_5051
    The command installs the new Splunk UBA software, restarts Splunk UBA, and then restarts the data sources.

Apply security patches on your Linux operating system

Perform the following tasks to apply the latest Linux operating system security patches:

  1. Log in to the Splunk UBA server as the caspida user.
  2. Run the following command to stop Splunk UBA and all services:
    /opt/caspida/bin/Caspida stop-all
  3. Run the following command to install the security plugin:
    sudo yum -y install yum-plugin-security
  4. Run the following commands to check for any available security updates:
    sudo yum updateinfo list security all
    sudo yum updateinfo list sec
    
  5. Run the following command to update all packages with the available security updates:
    sudo yum update --security -y
    sudo yum --security update-minimal
    
  6. Reboot the system:
    sudo reboot
  7. Run the following command to start Splunk UBA and all services:
    /opt/caspida/bin/Caspida start-all

Next Steps

Verify a successful upgrade of Splunk UBA.

Last modified on 12 January, 2022
PREVIOUS
Upgrade a single node AMI or OVA installation of Splunk UBA
  NEXT
Upgrade a distributed AMI or OVA installation of Splunk UBA

This documentation applies to the following versions of Splunk® User Behavior Analytics: 5.0.5.1


Was this documentation topic helpful?


You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters