Splunk® ODBC Driver

Install and Use Splunk ODBC Driver

Download manual as PDF

This documentation does not apply to the most recent version of ODBC. Click here for the latest version.
Download topic as PDF

Configure the Splunk ODBC driver to work with Microsoft Excel

To use the Splunk ODBC Driver to get Splunk data into Microsoft Excel:

  1. Open a new worksheet in Excel.
  2. Click the Data tab.
  3. In the Data tab, click Get Data > From Other Sources, and click From ODBC.
  4. In the From ODBC window, select Splunk ODBC from the Data source name (DSN) dropdown menu, and click OK.
  5. In the Navigator window, select ODBC > All from the Display Options menu.
  6. In the ODBC driver window, enter the username and password for Splunk instance, and click Connect. Microsoft connects to your Splunk Enterprise server.
    This screenshot shows the configuration menu. The list includes Username and Password.
  7. In the Navigator menu, select your saved search from the list, and click Load.
    This screenshot shows the list of available tables. The list includes the user's Splunk saved search.

The saved search may load slowly.

For more information, see "Use the Query Wizard to define a query" on the Microsoft Office website.

Last modified on 08 May, 2020
PREVIOUS
Load Balancer Configuration
  NEXT
Configure the Splunk ODBC driver to work with Tableau Desktop

This documentation applies to the following versions of Splunk® ODBC Driver: 3.0.1


Was this documentation topic helpful?

Enter your email address, and someone from the documentation team will respond to you:

Please provide your comments here. Ask a question or make a suggestion.

You must be logged into splunk.com in order to post comments. Log in now.

Please try to keep this discussion focused on the content covered in this documentation topic. If you have a more general question about Splunk functionality or are experiencing a difficulty with Splunk, consider posting a question to Splunkbase Answers.

0 out of 1000 Characters