Docs » Instrument back-end applications to send spans to Splunk APM » Instrument Ruby applications for Splunk Observability Cloud » Ruby agent compatibility and requirements

Ruby agent compatibility and requirements 🔗

Meet these requirements to instrument Ruby applications for Splunk Observability Cloud.

Supported libraries and frameworks 🔗

The Splunk Distribution of OpenTelemetry Ruby instruments numerous libraries and packages. For a complete list, see Supported libraries in the OpenTelemetry documentation.

Ensure you have supported Ruby and library versions 🔗

The agent of the Splunk Distribution of OpenTelemetry Ruby is compatible with Ruby 2.6 and higher.

Install and configure the Splunk OpenTelemetry Collector 🔗

The Splunk Distribution of OpenTelemetry Ruby exports application traces and spans to the Splunk OpenTelemetry Collector, which also collects system metric data and logs.

To send application traces and spans to Observability Cloud, install the Splunk OpenTelemetry Collector for your platform. The following distributions are available: